Update PHP and WordPress

To optimize your WooCommerce store’s performance and security, it should be running the minimum supported versions of PHP and WordPress.

This keeps your business running smoothly and creates the best online experience for customers.

WooCommerce Minimum Requirements ↑ Back to top

The most current release of WooCommerce and required WordPress and PHP versions should power your website, not only for security reasons, but also to take advantage of all available features and functionality.

WooCommerce version Minimum supported WordPress version Minimum supported PHP version
3.9 – next 5.0 7.0
3.8 – current 4.9 5.6
3.6 4.7 5.2

The next sections show you how to find out which versions of WooCommerce, WordPress and PHP are installed.

WooCommerce version ↑ Back to top

To determine which version of WooCommerce is running on your site:

  1. Go to Plugins on your Dashboard.
  2. Find WooCommerce.
  3. Look at the version.

We recommend updating to version 3.8 if not already installed and running on your site. More info at: Updating WooCommerce.

WordPress version ↑ Back to top

To determine which version of WordPress is running on your site:

  1. Go to WooCommerce > Status on your Dashboard.
  2. Go to WordPress environment.
  3. Find WordPress version.

If the WordPress version on your site does not meet the minimum listed in the table above, go to Update WordPress (insert URL after publishing).

PHP version ↑ Back to top

To determine which version of PHP is running on your site:

  1. Go to WooCommerce > Status on your Dashboard.
  2. Scroll down to Server environment.
  3. Find PHP version.

If the PHP version on your site does not meet the minimum listed in the table above, go to Update PHP (insert url after publishing).

Update WordPress ↑ Back to top

WordPress is the software that powers your store and provides WooCommerce with the underlying framework on which to build the optimal eCommerce experience.

Why update WordPress ↑ Back to top

  • Security

WordPress is the world’s most popular content management system and therefore a target for hackers. The WordPress team works on a rolling basis to fix, improve and harden security.

  • New features

WordPress adds features for plugins on which to build and develop. That means new WooCommerce features are dependent on newer versions of WordPress, and you need both to take advantage.

How to update WordPress ↑ Back to top

WordPress recommends that you update to the latest version upon release.

  1. Make a backup before performing an update in case anything unexpected happens. Instructions at: Backups – Automatic and Manual.
  2. Update WordPress.
    • Go to Dashboard > Updates > WordPress Updates.
      or
    • Follow steps outlined at Updating WordPress, given by the WordPress Support team.

Update PHP ↑ Back to top

Your WooCommerce store is faster and more secure by running the latest version of PHP.

Why update PHP ↑ Back to top

PHP is the coding language that WordPress and WooCommerce run on and is set on a server level by your hosting company that you can typically control within your hosting panel.

  • Performance

The latest version of PHP has been developed to be more performant and efficient than former versions of PHP, so updating can make your WooCommerce store up to 3-4 times faster.

  • Security

PHP is the world’s most popular web programming language and, similar to WordPress, is a target for hackers. Running the latest version of PHP ensures that loopholes in older versions  cannot be exploited because the team is consistently making improvements.

How to update PHP ↑ Back to top

  1. Make a backup before performing an update in case anything unexpected happens. Instructions at: Backups – Automatic and Manual.
  2. Follow instructions at Update PHP from the WordPress.org website. It gives details and a template you can copy/paste in requesting help from your hosting provider to upgrade your version of PHP.

WooCommerce - the most customizable eCommerce platform for building your online business.

Back to the top