Troubleshooting 101: Plugin Causing Fatal Error

If you have a fatal error on your site that is preventing you from accessing the WordPress Admin, you can take the following steps to correct this.

Pinpoint the Error ↑ Back to top

Here is an example of an fatal error similar to what you may see on your site:
 Fatal error: Call to a member function get_cart() on a non-object in .../html/wp-content/plugins/example-plugin-for-woocommerce/woo-integration/example-cart.php on line 2117  You will notice the message references /wp-content/plugins/example-plugin-for-woocommerce/ as the cause of the error. This means we need to either try updating that plugin or disable it to get around the error.

Log in to your site via FTP ↑ Back to top

Since you cannot log into your site via the WordPress Admin, accessing the folders containing these files via FTP is our only option.

If you are not familiar with how to connect to your website using FTP, it is best if you contact your hosting provider for further instructions.

Rename the conflicting plugin folder ↑ Back to top

Once you’ve logged into your site, navigate to the conflicting plugin folder.

plugin-conflict-folder-renaming

By renaming the plugin folder you’ve effectively ‘disabled’ it, allowing you to once again access your WordPress Admin, which would then display the following error:

plugin-conflict-errors

The plugin ‘does not exist’ because we renamed the folder.

Resolve the root of the issue ↑ Back to top

Many times we find customers contact us in support due to a conflict with an outdated third party extension or theme. If the plugin or theme was not developed and purchased directly from WooCommerce.com, we are not able to help troubleshoot this issue further. At this point, we would have to ask that you please contact the third party theme or plugin developer directly for assistance.

Updating is the most important step towards getting a quick resolution ↑ Back to top

Woo product causing error

If the theme or plugin causing the error is determined to be a Woo product, ensure that you have the latest version of the theme/plugin before contacting us.

To confirm you are running the latest version:

  1. Log into WooCommerce.com and go to the My Downloads page.
  2. Locate the product to confirm the version number matches the version number of the plugin on your site.

If updating the product does not help, you can open a new ticket and our Happiness Engineers would be happy to assist you.

Third-party product conflicts ↑ Back to top

When purchasing themes or extensions from third party developers, it can be helpful to ensure that the developer is reliable and responsive before you purchase or install the extension on your site.

If they do not stay up to date with WooCommerce API updates that are announced on woocommerce.wordpress.com, you run the risk of their files being outdated and possible conflict with new versions of the API.

 

WooCommerce - the most customizable eCommerce platform for building your online business.

Back to the top