Storefront Requirements & Version Support

Storefront Requirements ↑ Back to top

Storefront follows the same server requirements as WooCommerce core.

Storefront is designed to work well with WooCommerce, but the WooCommerce plugin is not required. Storefront can be used as a standalone WordPress theme without WooCommerce active.

Version Support ↑ Back to top

From Storefront 2.5.7, Storefront has an L-2 sliding window support policy for WordPress and WooCommerce. This is based on the WooCommerce core policy.

In practice, this means that Storefront will be tested with the latest versions of WooCommerce and WordPress at the time of release. Issues or compatibility bugs affecting the previous two releases of WordPress or WooCommerce will be triaged and fixed as time permits; issues only affecting older versions will not be fixed.

For example, when Storefront 2.5.7 is released, it will support the following versions of WordPress and WooCommerce:

  • WordPress 5.4.1 – the most recent version of WordPress
  • WordPress 5.3.3, WordPress 5.2.6 – the latest release from two previous release branches
  • WooCommerce 4.2 – the most recent release of WooCommerce
  • WooCommerce 4.1, WooCommerce 4.0 – the last two releases of WooCommerce

WooCommerce - the most customizable eCommerce platform for building your online business.

Back to the top