Server Requirements

Minimum Requirements ↑ Back to top

The first step in setting up your WooCommerce-powered online store is to install WordPress and the WooCommerce plugin itself. But before doing so, you should check that your hosting environment meets our minimum requirements. These are:

  • PHP 5.6 or greater
  • MySQL 5.6 or greater
  • WooCommerce 2.5 requires WordPress 4.1+
  • WooCommerce 2.6 requires WordPress 4.4+
  • WP Memory limit of 64 MB or greater (128 MB or higher is preferred)

You should also check WordPress minimum requirements.

PHP 5.2 reached end of life in 2011 and is no longer maintained meaning it could be a security risk. See the list of supported PHP versions for current releases.

Optional Items ↑ Back to top

Some other optional things that may be required include:

  • CURL or fsockopen support for PayPal IPN
  • Some of our extensions require SOAP support
  • An SSL certificate if you wish to install direct payment gateways
  • Multibyte String support if you’re running a non-english store
  • If you want WordPress pretty-permalinks, there are some additonal requirements listed here

You can check if your server has the items listed above after installing WooCommerce from the System Status page.

Moving Hosts ↑ Back to top

Need a new host? Check out our hosting partners here or dedicated WordPress web hosts listed here.

You can read this article on moving content between hosts, and to help you move content, this plugin is very good.

 

WooCommerce - the most customizable eCommerce platform for building your online business.

Back to the top